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Introduction

Perhaps the strongest feature of FileMaker Pro is its ability to transfer data quickly and easily. This document covers two categories of data transfer: importing and exporting data between FileMaker Pro and other applications and sharing files across a network, including cross-platform file-sharing. One aspect of file sharing is file protection, which is achieved by defining access privileges for users based on passwords and groups.

The Ins and Outs of Importing & Exporting

Importing data between applications involves copying the data from one file (the source file) to another file (the destination file). The source file and the destination file may have been created using the same application or using two different applications or types of applications. For example, you can import records from one FileMaker Pro file into another, or you can import data from a file created in another database, in a spreadsheet, or in a word processing application. Exporting data is pretty much the same thing as importing. As with importing, you can export records from one FileMaker Pro file to another or to a file in a different application.

Working Within the Limits

Importing and exporting files is quite simple in FileMaker Pro, within a set of clearly defined limits. These limits are described in the following table taken from the User's Guide and are explained fully there.

       Item  Limitation

       File formats for import
FileMaker Pro, Tab-Separated Text,





Comma-Separated Text, SYLK, DIF, WKS, BASIC,





Merge, ClarisWorks, DBF (dBASE III and IV)

       File formats for export
Tab-Separated Text, Comma-Separated Text, SYLK,





DBF (dBASE III  and IV), DIF, WKS, BASIC, 





Merge, FileMaker Pro, Edition File

       Picture formats for import      
Encapsulated PostScript, TIFF, PICT, MacPrint,






QuickTime movies

Importing Procedures: Three Basic Steps 

You can import records from a variety of file formats into FileMaker Pro. An example of importing data from a Microsoft Excel worhsheet into FileMaker Pro is presented below. 

[image: image1.png]Import Field Mapping

View By [Importorder
Dt i “SAMPLE Sy K" Filds in: “SAMPLE syl Converted”
Froduct Tame [-3|Product Hame ]
Suier | ->|Supptier =
Catagory |->|Category
Quantty Per Unit |->] Quantity per Unit
UnitPrice SEINTTAGEAEY
=]
ean Data Record 10778 Detne Fet
® ddnew recards
©) Reptace data i current found set Cancel





There are three basic steps in importing records. 

These are:
Prepare the Destination File. 

Prepare the FileMaker Pro file into which the records are to be imported.

At the very least, this means defining all the fields into which data will be
copied. 

Note that if the source file is already prepared and you do not yet have a destination file, you can simply open the file with FileMaker and it will be converted into a FileMaker file. 

Prepare the Source File. For the most part, this means saving a copy of the file in a format with which FileMaker Pro can work, such as tab-separated, SYLK, DBF, and other format types. 

Initiate the Import Function. With the source file closed (FileMaker Pro will not import from an open file), invoke the import command from within FileMaker Pro. 

Importing from Excel

A worksheet created in Excel is not in a compatible format, so you will have to save it into one of the formats that FileMaker can import from. Assuming that you have already prepared the destination file, you can use the following procedures to prepare the source file and initiate the import function.

       To prepare the source file:

           1.
Open the Excel file from which records are to be imported. 

           2.
Open the File menu, and select the Save As option. 

           3.
In the dialog box that appears, open the Save File as Type pop-up menu, and select SYLK  (Symbolic Link). 

           4.
Now, enter a file name in the field entitled Save Current Documents as:. You can keep the original name, but be sure to add ".slk" to the end to distinguish this version of the file from the original. 

           5.
After specifying the file type and file name, click on the Save button to complete the action. 

           6.
Quit Excel. 

To initiate the import function:

           1.
Open the destination file. 

           2.
Open the File menu, and select the Import/Export pop-up menu. From the pop-up menu, select the

 Import Records option. A dialog box appears asking you to identify the source file. 

           3.
You can limit the types of files displayed in the menu by specifying a format using the File Type pop-up menu. Your Excel file should appear if you have either All Available or Tab-Separated Text selected. 

           4.
When you find the desired file, select it and click the Open button. You are automatically taken to the Import Field Mapping dialog box. 

5.
The Import Field Mapping dialog box contains two lists. The first displays the data contained in the first row of the Excel worksheet, in this case the column headings. The second list displays the labels of all currently defined fields in the FileMaker Pro file. The purpose of this dialog box is to: (1) specify which fields you want to import from the source file (Excel), and (2) match those up to the corresponding fields in the destination file (FileMaker Pro). 

a.
With the arrange tool, move the field labels so they correspond to the appropriate element from

       Excel. 

b.
Click in the space between the two lists to create an arrow, indicating that the Excel data shouldbe copied into the FileMaker Pro field. 

c.
If the destination file does not have enough fields, you can define new ones from within the dialog box by clicking on Define Fields. 

d.
If you are unsure of the data in Word, use the Scan Data arrows to view the records one-by-one. 

e.
Notice the two radio buttons at the bottom of the dialog box. If you are importing records into an empty Filemaker Pro file, click on the Add new records button. 

           6.
When you have completed the import specifications, click OK. A message box should appear displaying the status of the import. 

           7.
Finally, you are returned to the FileMaker Pro file. Flip through the new records to check the accuracy
of the import. 

Importing Data from Other Applications 

Importing data from any other file or application type will follow almost the same steps as this example. The only difference will be the format of the source file. If, for example, you were importing data from an Access Database into FileMaker Pro, you would export the table you wanted to a file in a compatible format, like dBASE or SYLK, before importing it.

Importing to an Existing File

The example above assumes that you are basically converting a Word or Excel file to a FileMaker Pro file.

Another way of importing, however, is to update an existing FileMaker Pro file with data from another file, which also may not be an FileMaker Pro file. FileMaker Pro can handle updates that involve either adding a set of new records to the file or adding new data to existing records. For the first situation, the procedures are identical to those described above. For the second, however, the steps are slightly different.

To add new data to existing records:

           1.
Open the FileMaker Pro destination file and define the new fields to which data will be imported. 

           2.
If only a sub-set of the records are to be updated, perform a Find to create a Found Set of those records. 

           3.
Follow the steps outlined under To prepare the source file: above. 

           4.
Follow steps 1-5c under To initiate the import function:, making sure to put a check mark next to only those fields which are to be updated. 

           5.
DO NOT click the Add new records radio button at the bottom of the Import dialog box. Instead, click the button to Replace data in current found set. 

This will copy the specified data from the source file into the appropriate fields in the existing records of the FileMaker Pro destination file. 

Exporting

The procedures for exporting files from FileMaker Pro are pretty much the same, regardless of the application to which you're exporting, as long as the application uses a compatible file format. While exporting is the opposite of importing, the steps for exporting FileMaker Pro records are NOT simply the reverse of the import procedures. The difference is that the source document does not have to be created in advance; it can be created as part of the export. Export procedures are outlined below with an example involving Excel.

To export a FileMaker Pro file:

1.
Having opened the FileMaker Pro file, go to the File menu and select Import/Export. 

When the pop-up menu appears, select Export Records. 

The Export dialog box appears. 

2.
In the Export dialog box: 

     a.
Specify where you want the new file saved. 

     b.
Type a new file name in the Export To: field. When you begin typing in this field, the New button becomes active. 

     c.
In the File Type field, specify the appropriate file format. For example, if you are exporting to an Excel file, specify SYLK; to a Word file, specify Tab-Separated Text. 

     d.
Click New when you are done. Then the Export Field Order dialog box will appear. 

3.
The Export Field Order dialog box allows you to do two things: (1) specify the fields in the FileMaker Pro file from which you want to copy data, and (2) indicate if you want the output formatted or not. 
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     a.
Doubleclick on each field from which you wish to export data, or select it and click on Move to move it over into the Field Order list. 

            i.
If you wish to export subsummaries, you must first sort your data, just as you would to display subsummaries in a report. Select a summary field in the Field Order list and click on the Summarize by... button. 

           ii.
In the Summarize by dialog, click to the left of each field you want to summarize by.

 Your choices come from fields you used to sort your records. Click OK. 

     b.
Often, the only active radio button at the bottom of the screen will be the one indicating Don't format output. However, when both options are active you can specify whether or not you want the output formatted. 

     c.
Click OK to continue the export function. 

           4.
When you click OK in this dialog box, you are returned to the FileMaker Pro file from which you began the export. To verify the accuracy of the export, you must open the file to which the records were exported. 

           5.
Sometimes, you will not be able to open the new file automatically. For example, Excel does not know that the file you saved in SYLK format is destined to be an Excel file, and (if you are on a Mac) your computer will ask you if you want to open it in Teach Text. In this situation, you must open Excel first  and then, from within the program, open your new file using the Open command in the File menu.

There may be some idiosyncrasies with exporting to other applications as well. For example, while Word will open a Tab-Separated Text file, once it's open, you will have to import the data into a table if  you want it in that format. 

Introduction to File Sharing

       The second aspect of data transfer in FileMaker Pro is sharing a common file across a network. When a file is shared across the network, multiple users can access that file at the same time, viewing it simultaneously or taking turns updating it. FileMaker 3.0 supports file sharing on MacIPX (IPX/SPX for PCs), TCP/IP and  AppleTalk (for Macs only) networks. To exploit this feature, you must be connected to a network and have the right software to use the connection. If you are connected to a network and want to share a FileMaker Pro file with other users on the network, you first have to define the file as multi-user, then you must select the network protocol that you want to use.

To define a file as multi-user:

    1.
Open the FileMaker Pro file to be shared. 

    2.
Open the File menu. The current sharing status of the file is displayed: Single-user means file sharing is not turned on;

Multi-user means it is. If you want to change the current status, simply click on the current value to toggle to the other value. 

To select a network protocol:

           1.
Go to the Edit menu. Select Preferences.... 

           2.
The last item under General preferences is a pop-up menu which lets you select the appropriate network protocol. If you are not connected to a network, it should read "<none>." 

           3.
When you click OK, a dialog box will warn you that you must restart FileMaker to put the change into effect. Quit FileMaker and restart it. 

The Host and her Guests

       FileMaker Pro uses a peer-to-peer sharing system in which the first person to open a shared file becomes the host, while any subsequent users become the guests. The host has no special privileges in terms of access to the data, but that person does have a few options not available to the guests: defining fields, reordering layouts, defining groups, changing access privileges, saving copies of the file, changing the file to single-user, and closing the file. For most of these actions, however, the host will need to ask all guests to close the file (see below).

Opening a Shared File

       For the host, opening the shared file is no different from opening any other FileMaker Pro file. For the guest, however, there may be an extra step. Depending on the network setup, the guest may have to choose Hosts from the Open dialog box. Then, if there are zones defined for the network, the guest must choose the name of the host's zone before the file names will appear. If the guest is using the TCP/IP protocol, he can connect to a remote host by clicking on Specify Host in the lower list. The guest must then enter the IP address of the host to add that host to the list. In addition, the maximum number of guests who can access a single file using IPX or AppleTalk at one time is 25, so depending on your situation, it is possible that some users will occasionally be denied access to a file.

Saving and Closing a Shared File

       FileMaker Pro saves files through the host, and for that reason, the host cannot close the file without all the other users closing it first. If the host attempts to close a file that is simultaneously being accessed by one or more guests, the following message appears: "Waiting for 1 guest(s) to close file. Click Ask to ask all guests to close this file." At this point, the host needs to click on the Ask button. This will cause the following message to display on the screens of all guests, "THE HOST would like you to please close 'this file's name' as soon as possible. (Will attempt automatic close in 30 seconds.)" This message will not go away until the guests click OK. They should then close the FileMaker Pro file when they are returned to it. When all guests have closed the file, the close action originally initiated by the host will be automatically completed.

Defining Access Privileges

       Just because you set a file as multi-user does not mean you want to permit free access to that file. To ensure the security of your files, FileMaker Pro allows you to restrict access to shared files. This is a three step process, involving: (1) Defining groups and passwords for each file, (2) Assigning access privileges to the groups and passwords, and (3) Training those with access to shared files in the use of passwords. Briefly, the difference between a group and a password is: groups define a user's access to resources (e.g., specific layouts or specific fields within a layout); passwords define a user's activities within a file (e.g., designing layouts, editing records, defining scripts). Groups are defined at a higher level than passwords: a single group may be associated with a sub-set of one or more passwords, while an individual password is associated with only one group.

To set access privileges for a set of users:

1.
Open the File menu, and select Access Privileges. When the pop-up menu appears, select Define  Groups. The Define Groups dialog box appears. 

2.
The Define Groups dialog box allows you to create user groups for which you will define access privileges to resources in the file and to which you may associate one or more passwords. 

   a.
In the Group Name field, type in the name of the first group for which you want to define access. 

   b.
Click Create. The Define Passwords dialog box then appears. 
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3.
The Define Passwords dialog box allows you to define the passwords which will enable access to the file, and to define the parameters of access in terms of what actions can be performed by users of  each password. 

a.
In the Password field, enter the name of the first password you wish to define. 

b.
Under the Privileges menu, click to place an "X" in the box next to any activity to which you want users with this password to have access. NOTE: Within every file for which access privileges are defined, there must be at least one Master Password, a password with Access to the entire file. 

c.
When you have finished defining the passwords and their access privileges, click the Access button to display the Access Privileges dialog box. 

[image: image4.png]Access Privileges for File “Register30.fp3”

Groups Passwords Layouts Fieids
) ][ Woppuhapey [ [* Pamben ][ CherCo @
R it ([ pondnctase [0 clas con acsr]
o Classes Found  Clazs Code Coun|
© Crace Rt~ Atte] || Chcs Code Count]
© Crace Rotl-Enter] || @ Course Code
© Clazs Roll-Enter] || @ CoursaCodsanac]
© ClazeRall- atte] || @ Chass I umber
© ClaceRoll- Auto] | @ Chss I umbar
© Clacs Roll-Enter] || o SoftwareAndTit
© ClazsRal-Enter{ | o Ciass Archived
© Find & Clasz ~pr] | o Student 1D Rumbe
o Chasses-Listvig | o Ciass Date
o Craczez -Form ] | o Chss Date Text
& Standard o Time n
© Time n Caulst]
o Time out
=] =] [5]| Time
o hoosssible s Motsecessible o Resdonly

8 These Tinks are locked until s group i seloted





4.
The Access Privileges dialog box lets you: (1) Associate each password with a group, and (2) define the access to resources for those groups. 

     a.
Select the group to be defined by clicking its name under the Groups menu. 

     b.
Click the bullets next to the passwords you want to associate with the selected group. 

     c.
Select the access status for each resource listed under the Layouts and Fields menu.

Remember, a password's access to these resources is defined through its associated group.

 You can define access to these resources at three levels: 

       Bullet Type   
Group's Access to Resource

       Solid           
Group has complete access

       Open            
Group has read-only access

       Grayed          
Group does not have access

5.
After you have defined access privileges for each of the groups, click Done. You are returned to the Define Groups dialog box. 

6.
In the Define Groups dialog box, click Done. FileMaker Pro will display a message box asking you to confirm the Master Password for the file, the Password that lets you access the entire file. 

BE SURE TO CHOOSE A MASTER PASSWORD YOU CAN READILY REMEMBER, AS YOU CANNOT RECOVER OR CHANGE THE MASTER PASSWORD WITHOUT THE CURRENT ONE. 

A Note on Cross-Platform Sharing

       FileMaker Pro files can easily be shared across platforms (i.e., between Windows 3.1, Windows 95, and Macintosh). For information on some of the things you need to think about when designing a file to be used cross-platform, refer to your FileMaker Pro User's Guide.

[image: image5.jpg]



Prepared by Peter J Faulks

14/4/00 11:41:11 AM

( PIP Multimedia & Training

PO Box 41

Riverton Forum

Phone: 
9457 0747

Fax:    

9457 0444

Mobile: 
0416 187 937

EMail: faulksp@highway1.com.au

�





�





�





�





�








Page


